Firefox 1.5-exploit voor Linux en Mac OS X

  • Bron (c) 2006, VirusAlert

Firefox versie 1.5 kampte afgelopen week met een exploit die gebruik maakt van een bug in zowel de Linux- als de Mac OS X-versie. De bug is al weer gerepareerd in versie 1.5.0.1 van de browser. De Windows-versie daarentegen is op dit moment nog veilig voor de kwaadaardige code. De code van deze exploit heeft bijna een gigabyte geheugen nodig. Hierdoor zal de code op sommige systemen slecht of niet functioneren. De webpagina TechWeb vermeldt dat de code die van de bug gebruikmaakt is gepubliceerd op de Metasploit Project site. Dit is een website die regelmatig exploit-modules uitgeeft voor zijn Framework-tool. Deze exploit bewerkt het geheugen van Firefox waardoor hackers vervolgens hun eigen programma’s kunnen starten om zo de computer onder controle te krijgen. Voor firefox gebruikers is het aan te raden de browser versie 1.5- zo spoedig mogelijk bij te werken.